ASIAIR connection error with rainbowastro RST-135

Astrophotography has never been easier

Moderators: yang, Sam, Ji.zwo, lancer jiang

Post Reply
jjerugss
Posts: 2
Joined: Wed Jun 05, 2019 12:04 am

ASIAIR connection error with rainbowastro RST-135

Post by jjerugss » Wed Jun 05, 2019 8:44 am

Dear Support team,

I have some problem to connect telescope(RST-135) in Asiair Apps.

Maybe they can be connected in three ways.

1. Asiair - USBtoRS232 - RS232toST4 - RST135
2. Asiair - USBST4 - RST135
3. Asiair - USBtoUSB - RST135

Rst-135 has ST4 guide port and USB port.

I tested (2) and (3). They failed.

At test (2), USBST4 is zwo products.
but It was not working. Maybe it is for PC.
I want you to check this.

At test (3), I use samsung galaxy tab2
Os is android and asiair app version is 1.2 ( I tested 1.1, too)
When I try to connect telescope in apps, “sync success” message is posted and turned off immediatley.
Please watch below url.
https://youtu.be/FDS2zTYfsT0
I don’t know what is problem..
Can’t Asiair be connected directly to mount?
Should it be connected through RS-232 only?

I didnt test (1). I have to make connector and cable myself.
Can it be connected to ST4 port?
Please, let me know pin map of Asiair’s USB-RS232 Cable?
If I know pin map, I will test RS232-ST4 connection.

Please, help me connect telescope.

Thanks,
kagaya.

W7AY
Posts: 19
Joined: Fri Jan 25, 2019 3:38 am

Re: ASIAIR connection error with rainbowastro RST-135

Post by W7AY » Wed Jun 05, 2019 3:16 pm

The ST4 port is for guiding only. It is not for ASCOM/INDI/INDIGO/ASIAIR control.

To use the ST4 port, you select "On-Camera-ST4" as the "telescope" in the Telescope Settings window of the ASIAIR app. Connect the ST4 port of the RST-135 to the ST4 port of the ZWO guide camera using a direct 6P6C RJ11 cable (like the guide cable that comes with a ZWO guide camera), and you can guide that way. I have sucessfully tested ST4 guiding on RST-135 using a ASI290-MM-Mini and a Borg 36ED as a guide scope, and using the Hubo-i hand controller to point the mount.

For PC control, the RST-135 can use a serial port (FTDI chip) at 115200 baud that is built into the USB connector of the RST-135. Just use a USB-Type-A to USB-Type-B cable to connect the RST-135 to the ASIAIR. In the ASIAIR v1.2 beta, the menu is named "RainbowAstro RST/MC700GE-II." In ASIAIR v1.1 app, select "RainbowAstro 150h."

The RainbowAstro RST-135 mount also supports WiFi connection for mount control. However, the ASIAIR does not yet support it. I have been able to control the WiFi port through ASCOM.

ASIAIR works somewhat with the RST-135. You can for example change slew speeds, use the slew buttons in the Main Camera window, and you can also change the tracking ON/OFF (the blue tracking LED on the RST-135 will obey the ASIAIR commands).

However, my ASIAIR crashes whever I execute a GOTO command from the ASIAIR's database. This happens on both the v1.1 ASIAIR app, and also the Beta v1.2 ASIAIR app.

I have not have a chance to test under dark skies yet to see if plate solve-sync-GOTO will also crash. I suspect that it will also crash.

With my iPad-ASIAIR and RST-135 combination, whenever I ask ASOAOR to execute a GOTO, the mount actualy slews to the correct location (as far as I can tell indoors), and the small window in ASIAIR that tells you that it is executing the GOTO even geos away after the slew is completed. However, the ASIAIR then loses connection with the mount. In my case, the Telecope menu became an empty menu and I could not even turn off the ASIAIR from the ASIAIR Settings window.

The ASIAIR app itself does not crash into the iPad OS itself, but the app is frozen, and I need to force quite from the iPad.

If I then repower the ASIAIR (without disturbing the power at the RST-135), I can actually reconnect to the mount, and ASIAIR even shows the correct coordinates from the end of the previous slew.

I suspect that there is something in the control protocol that is causing the RST-135 to crash the ASIAIR app (perhaps it worked with the RST-150h; but I do not have an RST-150h).

By the way, there is new firmware from RainbowAstro for the RST-135 that came out on June 3. I have applied the new firmware (version 190603), but it is still freezing the ASIAIR after a GOTO command.

Regards,

- chen

jjerugss
Posts: 2
Joined: Wed Jun 05, 2019 12:04 am

Re: ASIAIR connection error with rainbowastro RST-135

Post by jjerugss » Thu Jun 06, 2019 1:57 am

Dear chen,

Your reply is really helpful to me.

I will connect through ST4 tonight. ( On camera ST4).

And in case of USB connection, the App seems to be crashed in Android, too

In case of Wifi connection, maybe It is what the rainbowastro team should do.
For connection with asiair, the mount need to WiFi station mode. But RST-135 has not station mode function.

By the way, thank you again.

- Kagaya

W7AY
Posts: 19
Joined: Fri Jan 25, 2019 3:38 am

Re: ASIAIR connection error with rainbowastro RST-135

Post by W7AY » Thu Jun 06, 2019 5:33 am

Dear Kagaya,

I hope the ST-4 solution works for you until we can fully control the RST-135 through ASIAIR.

Here is additional information that may help you further:

Since RST-135 crashes with ASIAIR, I have been testing the RST-135 indoors (still cloudy here) through ASCOM - StellariumScope - Stellarium (even using a WiFi connection on the handcontroller) and I found that I can wirelessly control the mount from a Windows Surface Pro computer from Stellarium's planetarium.

So, you can still do everything wirelessly, but in addition to a tablet to talk to ASIAIR, you also need a Windows computer to talk to the RST-135. You can still guide by connecting the guide camera in the ASIAIR to the RST-135 ST-4 port. Additionally, you cannot sync the mount to a plate solution from the ASIAIR main camera.

To use ASCOM wirelessly, you will need to change the Communications menu in the handcontroller to use WiFi. Obtain the WiFi password from the handcontroller's WiFi Status window. The RST-135 should then appear as an Access Point (192.168.5.1) that Wndows can connect to.

The RST-135 ASCOM driver is available at the RainbowAstro web site.

If you need help with StellariumScope, the following web page may be helpful:

https://www.lightvortexastronomy.com/tu ... -ciel.html

Like GPS, the WiFi antenna is inside the Hubo-i hand controller. It appears to use WiFi Channel 1 on 2.4 GHz and the range is at least 10m from the handcontroller.

Since the mount is not connected to ASIAIR, you cannot take advantage of the ASIAIR plate solving, but you can center a star that is close to your DSO target in the ASIAIR main camera by using the direction buttons on ASCOM or the handcontroller, and then Sync the star with Stellarium. You can then use Stellarium to GOTO the nearby DSO object.

Using two computers is definitely very clumsy compared to using ASIAIR alone to do everything. Before the RST-135, I used ASIAIR plate solve with a Takahashi EM-11 mount, and I am spoilt by how easy and fast it is to acquire an object with the ASIAIR.

But at least using ASCOM-WiFi-Stellarium can help save some trips to use the handcontroller at the telescope to perform a GOTO from the handcontroller.

By the way, I had earlier mentioned that with an iPad, I could connect to the ASIAIR with the RST-135 USB port connected to the ASIAIR, and be able to slew, change slew speed, change tracking mode, etc. -- the ASIAIR program crashed only when I tried to perform a GOTO from ASIAIR. I later tested with a Samsung Tab A, and ASIAIR crashed immediately into Android once I tried to select the RainbowAstro mount.

- chen

Post Reply