ASICAP and ASI183MM Pro output files Issue

questions or suggestion about ASICAP software

Moderators: walkfaraway, chad

Post Reply
TimW
Posts: 7
Joined: Mon Sep 24, 2018 11:48 pm

ASICAP and ASI183MM Pro output files Issue

Post by TimW » Wed May 15, 2019 10:40 am

Hi,

When using ASICAP and my ASI183MM Pro to shoot videos of the moon I run into this issue.

Both PIPP and Autostakkert autodetect the videos as having a bayer RGGB format instead of mono.

Here I attach some examples of this:
pipprggb.PNG
pipprggb.PNG (11.17 KiB) Viewed 349 times
pipp2rggb.PNG
autostakkertrggb.PNG
This has caused me problems when having the manually choose to process videos as monochrome or colour frames input on PIPP. If I choose monochrome input then the final result introduces fake colour into the images with random blue and red pixels. If I choose colour input then it is fully greyscale (as I would expect from a mono camera), but the image sharpness is much worse! Can someone clarify with me whether a raw frame from a mono camera is treated as a monochrome or colour frame for the purposes of processing?

I dont know if I explained this very well. All I know is that I expected the software to detect the videos as mono but they think it has a bayer pattern...

Thank you in advance,

Tim

TimW
Posts: 7
Joined: Mon Sep 24, 2018 11:48 pm

Re: ASICAP and ASI183MM Pro output files Issue

Post by TimW » Wed May 15, 2019 10:43 am

An extra attachment as I am limited to only 3 for the first post:
sermonorggb.PNG
sermonorggb.PNG (7.96 KiB) Viewed 348 times
This is from a document about .SER format descriptions. See here

http://www.grischa-hahn.homepage.t-onli ... %20V3b.pdf

Based off of that information should I not expect to see the colour ID of my mono files as 0 ?

PIPP and also .SER Player read the files as having colour ID 8.

Is there any way to modify a .SER file via a config or something so I can try changing to value to 0 see if that fixes the problem?

Very confused.

Thanks again.

User avatar
walkfaraway
Posts: 64
Joined: Tue May 09, 2017 5:52 am
Location: lon=120.6 lat=31.3

Re: ASICAP and ASI183MM Pro output files Issue

Post by walkfaraway » Fri May 17, 2019 5:40 am

Hi Tim,
We tested the problem you described and it turned out to be a bug. We are sorry for trouble of the bug has caused you. We will fix this bug as soon as possible.
Thanks for your feedback.
Mouling Song
ZWO Software Engineer
Location:lon=120.6 lat=31.3
SuZhou China

Post Reply