ASICAP ubuntu win 10 not finding camera asi290

questions or suggestion about ASICAP software

Moderators: walkfaraway, chad

Post Reply
freestar8n
Posts: 11
Joined: Thu Jun 08, 2017 8:59 am

ASICAP ubuntu win 10 not finding camera asi290

Post by freestar8n » Sun Aug 04, 2019 1:09 am

Hi-

I have just set up ubuntu 18.04 in Windows 10 and am trying to run the latest linux version of ASICAP - but it is not finding an attached asi290mm camera. The full ASICAP gui comes up but it says No cameras were found.

It is version V1.6.1

But if I run the Windows version of asicap it finds the camera with no problem.

I am running it with the Xming server.

The only other errors I get are "failed to get the current screen resources" and QXcbConnection XCB error: 170

But the gui does come up.

Is there something else I need to do to allow connection to the camera in Windows Ubuntu?

I'm interested in working with the camera in linux and raspberry pi - so I hope to make this work.

Thanks for any help-
Frank

freestar8n
Posts: 11
Joined: Thu Jun 08, 2017 8:59 am

Re: ASICAP ubuntu win 10 not finding camera asi290

Post by freestar8n » Tue Aug 06, 2019 9:03 am

Well I guess I can rephrase this more specifically. I may be unusual in connecting to the camera via ubuntu within the windows subsystem for linux. And I am using Xming as the X server.

I am able to do python plotting - and the gui for ASICAP does come up. So - many things are working in the ubuntu shell, but I don't appear to have a low level usb3 connection to the camera.

When installing asicap it asked me for root password to install udev - and everything happened normally.

So - is there anything special I need to do to connect to the camera in ubuntu under WSL? Have others done this?

Is there a simple way I can see if the camera is available as a usb device? If I use Windows Devices and Printers - I see it there just fine.

Frank

freestar8n
Posts: 11
Joined: Thu Jun 08, 2017 8:59 am

Re: ASICAP ubuntu win 10 not finding camera asi290

Post by freestar8n » Wed Aug 07, 2019 12:10 pm

Well - I'm starting to think usb cameras just aren't supported yet in WSL - so this may currently not be possible. That's unfortunate because I thought I could do linux development with connection to asi cameras in WSL and xfer to raspberry pi.

But I guess what is needed is for WSL to support usb camera access. Apparently there is only limited support for USB devices currently.

Oh well. At least it doesn't appear to be an issue on the ZWO side.

If anyone finds out otherwise please post here.

Frank

User avatar
walkfaraway
Posts: 75
Joined: Tue May 09, 2017 5:52 am
Location: lon=120.6 lat=31.3

Re: ASICAP ubuntu win 10 not finding camera asi290

Post by walkfaraway » Mon Aug 19, 2019 6:53 am

I've never used Xming. When I need to run Linux on Windows, I use VMware workstation. So I'll describe how VMware works if it finds a camera device. I hope it will help you.

In the menu, find the portable devices option. Then I can see the name of the camera. Click on the name of the camera, so that the camera is checked. Then VMware can find the camera, and the Linux which installed in VMware can also find this camera.
portabledevices.png
Thank you.
Mouling Song
ZWO Software Engineer
Location:lon=120.6 lat=31.3
SuZhou China

freestar8n
Posts: 11
Joined: Thu Jun 08, 2017 8:59 am

Re: ASICAP ubuntu win 10 not finding camera asi290

Post by freestar8n » Sat Aug 24, 2019 5:58 am

Hi-

Thanks for the reply. My question is specific to running in Linux under Windows 10 WSL - which is a recent feature and it is different from VMWare.

Here is a link to WSL and WSL 2:

https://docs.microsoft.com/en-us/windows/wsl/wsl2-about

I think this is already a powerful addition to Windows and will allow nearly native Linux performance within the Windows environment - but right now it won't work for usb cameras because they aren't supported yet.

But when they are supported it may be a good way to run imaging apps in Linux within Windows. Just not there yet.

The good news is that under Windows WSL Ubuntu, ASICap does provide a fully functional gui - it just can't see the camera.

Ximg isn't really relevant here because it is just the x windows server running in windows that lets me see the gui. It is working fine and other x servers would also work.

Frank

User avatar
walkfaraway
Posts: 75
Joined: Tue May 09, 2017 5:52 am
Location: lon=120.6 lat=31.3

Re: ASICAP ubuntu win 10 not finding camera asi290

Post by walkfaraway » Mon Nov 25, 2019 8:09 am

I'm so sorry for the issue.
Mouling Song
ZWO Software Engineer
Location:lon=120.6 lat=31.3
SuZhou China

Post Reply