Testing on Moto G4, error code 16

questions or suggestion about ASICAP software

Moderators: walkfaraway, chad

Testing on Moto G4, error code 16

Postby kancore » Wed Feb 22, 2017 12:47 am

Hi everyone,

I installed the app on my Moto G4 and tried to connect it to an ASI120MM-S but it's not working. I'm getting an error code 16. In the documentation I found it means "ASI_ERROR_GENERAL_ERROR". Is this the kind of error you get when the phone cannot supply enough power to the camera? Is there a way to fix this?

I'm not an android developer, but I may be able to understand a little if I could debug this.. Could someone give me a hint about what to do?

Thanks
kancore
 
Posts: 1
Joined: Wed Feb 22, 2017 12:40 am

Re: Testing on Moto G4, error code 16

Postby chad » Wed Feb 22, 2017 10:23 am

Dear kancore,
Thanks for your testing。
Because it is only a sample demo, so SDK doesn't contain all of the ASI cameras. Unfortunately,ASI120MM-S is not include in the SDK :( . So it is not your phone's power supply problem :) .
As you know, Android has too many versions and machines,So We are do our best to make all android system can support all cameras.
If you have any other problem, please let us konw。
Best Regards
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China
User avatar
chad
 
Posts: 235
Joined: Thu Feb 09, 2017 4:58 am

Re: Testing on Moto G4, error code 16

Postby ray » Tue Feb 28, 2017 8:10 am

Hi kancore,

New demo has been published on http://astronomy-imaging-camera.com/software/ASISDK_ANDROID.zip.
ray
 
Posts: 14
Joined: Tue Feb 14, 2017 5:26 am


Return to ASICAP

Who is online

Users browsing this forum: No registered users and 1 guest