Ascom Driver memory leak with ASI6200

any question related to our SDK and driver

Moderators: yang, Support@ZWO

Post Reply
Xplode
Posts: 4
Joined: Thu Feb 20, 2020 9:51 am

Ascom Driver memory leak with ASI6200

Post by Xplode » Thu Feb 27, 2020 12:45 pm

I'm using SGP for capturing with the ASI6200, i see large differences in memory usage with the native driver (which is unsuported in SGP) and the Ascom driver, it get to the point where i'm losing images because of memory errors.
QHY had the same problew with their Ascom driver and found a memory leak and fixed it, i hope you can do some testing too and fix the Ascom driver so it's stable.


I can also mention that i'm having a problem where the first image after i connect to the camera sometimes doesn't download, stopping the download of the image and doing a new capture works ok.

Camera is connected directly to the pc with Lindy USB3 cable.

PC specs
i5-8500T
16GB ram
Win 10 Pro

User avatar
Support2@ZWO
Posts: 668
Joined: Thu Feb 09, 2017 4:58 am

Re: Ascom Driver memory leak with ASI6200

Post by Support2@ZWO » Fri Feb 28, 2020 1:43 am

Hi Xplode,
According to your description, I am not sure if it is a memory leak for us.
If there is a memory leak, according to our design, the camera should not run normally after that.
And for your problem, I suggest you send an email to our support, we will help you to enable the SDK log, maybe that will help us to find out what happened.
Thanks
Chad
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China

Post Reply