[SOLVED] "camera removed" error when trying to open camera

any question related to our SDK and driver

Moderators: yang, chad, ray

Post Reply
MonsterMax
Posts: 10
Joined: Thu Oct 13, 2016 4:32 pm

[SOLVED] "camera removed" error when trying to open camera

Post by MonsterMax » Thu Dec 19, 2019 11:25 pm

tldr; Make sure you can access the camera without being root by calling "sudo install asi.rules /lib/udev/rules.d" from the lib subdir of the SDK. Got rusty in the past three years...

Hey guys,
it's been almost three years since my last post :D I am writing Julia bindings for the camera library and already got quite far, but when I try to open my old USB2(!) ASI120MM camera, I get the error "ASI_ERROR_CAMERA_REMOVED" (in both C and Julia). On my old Laptop (which I didn't format since back then, runs a patched kernel) the error does not appear. If you think this is still related to the old USB2/3 incompatibility, stop reading here and comment :D So to nail things:

ASI 120MM USB2 connected to USB3 port
Camera Firmware 3.1.7 compatible / non-compatible (error occurs with both)
libASICamera2.so.1.14.1119
Debian 10, Kernel 4.19.0-6-amd64
libusb-0.1-4:amd64 2:0.1.12-32 amd64 userspace USB programming library
libusb-1.0-0:amd64 2:1.0.22-2 amd64 userspace USB programming library

Tell me if you need the exact setup of my old laptop.

Code to reproduce error:
--------------------
#include <iostream>
#include "ASICamera2.h"

using namespace std;

int main(){
ASI_CAMERA_INFO info;

cout << ASIGetNumOfConnectedCameras() << endl;
cout << ASIGetCameraProperty(&info, 0) << endl;
cout << info.Name << endl;
cout << ASIOpenCamera(0) << endl;
return 0;
}
------------------
Output:
1
0
ZWO ASI120MM
5 (ASI_ERROR_CAMERA_REMOVED) <- expected 0 (SUCCESS)here


PS1: i think you should write proper entries into your SDK changelog, not just "fixed some bug" ;-)
PS2: Have you thought about open-sourcing your camera drivers? I think by now you have so much headstart into the market it won't hurt you.
PS3: I'm considering to buy a new deep sky camera and would love to get these things to run beforehand :)
PS4: I find it quite cool that you still output the SDK.

User avatar
chad
Posts: 660
Joined: Thu Feb 09, 2017 4:58 am

Re: [SOLVED] "camera removed" error when trying to open camera

Post by chad » Wed Dec 25, 2019 2:01 am

Dear Sir,
Thanks for your advice.
For ps1, because our update speed for our SDK is slow, and our SDK targets support all of our cameras. This causes a lot of bugs during each update, and most of the bugs are solved for one or two kind of cameras. So if it is described in details, the change log will be very very long.
For ps2, No and never. Some of our cameras had been copied on the market, they used our software directly. Because they do not need to bear the cost of software, and they also use cheaper hardware components inside the camera. so they have a very cheap price. If we opensource our driver, I think ZWO's brand image will be damaged overnight.
For ps3, 120 is our first generation product. And it is becoming less and less adaptable to current systems. Like this problem, I will try my best to help you with it, but I am not sure if we can solve it.
For ps4, Thanks.
For your problem, please email me: chad.cao(at)zwoptical.com. I think we can catch the log to check out what happened.
Thanks
Chad
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China

Post Reply