ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

any question related to our SDK and driver

Moderators: yang, chad, ray

Post Reply
sywong2000
Posts: 17
Joined: Sun Jan 07, 2018 2:45 pm

ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by sywong2000 » Mon Dec 09, 2019 5:50 am

Hi everyone

Anyone tried Ubuntu 19.10 on RPI4?
After Exposure, My ASI 120mm reported error. Tried to use indigo_server and error as:

indigo_ccd_asi[351, asi_read_pixels, 0xadf8d3d0]: Exposure failed: dev_id = 0 exposure_status = 3

Any ideas?
Stephen

wvreeven
Posts: 47
Joined: Mon Apr 01, 2019 7:06 am

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by wvreeven » Mon Dec 09, 2019 2:26 pm

Hi Stephen,

Do you have an ASI120MM (USB 2) or ASI120MM-S (USB 3)? The first one is not compatible with Linux (and MacOS and Windows 10) because it doesn’t implement the USB2 standard correctly. There is a “compatibility” firmware for that camera but it never worked for me. If you have an ASI120MM-S then it should work. I use it all the time with Ubuntu 18.04 and see no reason why it wouldn’t work with 19.10.


HTH, Wouter

sywong2000
Posts: 17
Joined: Sun Jan 07, 2018 2:45 pm

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by sywong2000 » Tue Dec 10, 2019 5:35 am

Wouter,
Thanks. Mine is 120mm USB2. However I was able to use it in ubuntu 16 (RPI3). I did read post about it's not compatible.
Just want to make use of it. It's a nice camera and for guiding I do not need USB 3.
I will search around to look for that "compatible" firmware and see if I get lucky.

Stephen

sywong2000
Posts: 17
Joined: Sun Jan 07, 2018 2:45 pm

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by sywong2000 » Tue Dec 10, 2019 5:49 am

viewtopic.php?f=21&t=10068&p=34807&hili ... are#p34807

Well looks like it does not work in newer OS. I just think although it's an old model, for guiding the camera did its job very well. Don't know why the issue not being fixed. It can work with ubuntu 16 not sure why it cannot work in 18 or later.

I hope someone in ZWO can read this and consider bringing the ASI 120mm back to live for newer OS. I use ASI 183mm as DSO camera Unfortunately the 183mm did not work in RPI3... so RPI3 only the guider works but not the CMOS, and in RPI4 only the CMOS works but not the guider.... :| :| :| :|

wvreeven
Posts: 47
Joined: Mon Apr 01, 2019 7:06 am

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by wvreeven » Tue Dec 10, 2019 8:36 am

The newer Linux kernels in Ubuntu 18.04 and up enforce a tighter use of the USB2 standard, which the ASI120MM (and MC) break. There is a lot of info about what's exactly wrong with the way this camera implements this standard only partially. It is actually a good thing that the kernel enforces this (the standard is there for a reason and devices that do not implement it properly may actually damage the horst that they are connected to) and it is a problem of the camera, not the OS.

ZWO have released a firmware to fix the camera but it only works in some cases and, like I wrote before, for me it never worked. I switched to an ASI120MC-S (USB3) camera and that works flawlessly. Anyway, if you want to try and flash the camera with the "compatibility" firmware then simple search the internet for ASI120MM and compatibility and you'll find much info and also this URL

https://astronomy-imaging-camera.com/software-drivers


Wouter

sywong2000
Posts: 17
Joined: Sun Jan 07, 2018 2:45 pm

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by sywong2000 » Tue Dec 10, 2019 9:40 am

Wouter,

OK thank you I understand. No wonder I seemed seeing someone to patch the kernel in ubuntu 18 and make the camera work (just for a while,I forgot where I saw it already). I have a ASI 178mc mainly for planetary imaging. I think I can use it as the guider cam.

Can't find the "compatible" firmware anymore in the download page. Reading from indilib someone patched the camera and afterwards it does not work. Better not to risk it...

btw - Do you know if the asi-mini works?

Thanks!

wvreeven
Posts: 47
Joined: Mon Apr 01, 2019 7:06 am

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by wvreeven » Tue Dec 10, 2019 12:51 pm

I don't own an ASI-mini but people on the indilib forum report that it works. Perhaps someone from ZWO can confirm this?


Wouter

User avatar
chad
Posts: 660
Joined: Thu Feb 09, 2017 4:58 am

Re: ZWO ASI 120mm exposure failure on ubuntu 19.10 RPI4

Post by chad » Thu Dec 12, 2019 3:12 am

Hi Sywong,
Here is an URL to download the copatiable firmware:
https://astronomy-imaging-camera.com/so ... FWTool.zip
And you can test it. For the Ubuntu19.10 on Rpi4, now we are not free to test it.
Thanks
Chad
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China

Post Reply