Page 1 of 1

WB_B setting affects ASI224MC RAW image

Posted: Mon Aug 12, 2019 6:53 am
by jochen
Hi,

I am using the ZWO ASI224MC. I like it very much. Thank you for developing and delivering such a great product!

I am experimenting with the SDK (version libASICamera2.dylib.1.14.0715) using the python bindings under MAC OS X High Sierra.

Because of the 12 bit AD converter, I was expecting to see only multiples of 16 in the returned pixel values if the image type was set to ASI_IMG_RAW16. However the blue (and only the blue) pixels returned also values in between. Interestingly it turned out, that the 'WB_B'-Setting affects the raw image, while the 'WB_R' setting does not. I haven't expected the WB-Setting to afect the raw image at all. With WB_B set to 50, I get the expected multiples of 16 only.

My question: Is there a reason, why WB_B is acively scaling the pixel values for RAW16 image mode, while WB_R does not?

Jochen

Re: WB_B setting affects ASI224MC RAW image

Posted: Thu Aug 15, 2019 3:13 am
by chad
Hi Jochen,
I am not sure what your mean is.
For white balance(WB), It usually means a coefficient. It is between 0.5 to 2. Mapped the value you set of WB, It is nonlinear.
When you set the 0, It means multiplying original data by 0.5. when you set the 50, it means the multiplying original data with 1, it is the original data. When you set 100, it will multiplying the original data with 2.
So if you want to get the Raw data without processed, you should set it to 50.
Thanks
Chad

Re: WB_B setting affects ASI224MC RAW image

Posted: Thu Aug 15, 2019 5:57 pm
by jochen
Hi Chad,

that's what I wanted to know: WB settings of 50 leave the original data unchanged.

I was confused about some strange behavior which I experienced in the SDK as well as in ASICAP: The WB_B setting behaved exactly as you described, while WB_R setting had no influence at all. However after once switching off (and on again) the "RAW data" option in ASICAPs Capture settings, the effect is now gone (don't know I did something wrong)

Thanks a lot

Jochen

Re: WB_B setting affects ASI224MC RAW image

Posted: Mon Aug 19, 2019 1:13 am
by chad
Hi Jochen,
Thanks.
We tested the WB on our side, it works fine. So I am not sure if it is a bug.
Can you repeat it every timeļ¼Ÿ If you can, please tell me the steps. We will follow it to have a try.
Thanks
Chad