Page 1 of 2

ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Sun Apr 10, 2016 11:20 pm
by opoloko
Hi all,

I bought a 120mm (usb2) for solar imaging, after reading that oacapture supports it. Sadly is not the I discovered later, many here have problems with oacapture connecting but not showing any preview or getting any image from the camera,

I already tried download the firmware update tool and both the normal and 'compatible' firmwares do not work.

I have on my astronomic software running without problems in a virtual machine, but the asi120mm is not compatible (and I read I'm not the only one). I also tried other recommended software like Astrogen, it doesn't work as well!

Curiously enough, PHD2 (2.6) WORKS PERFECTLY WITH ASI AND OSX, meaning it can get images without problems from the camera. This means there must be a way to get the camera working correctly on Mac!

I also tried as suggested on other threads, like opening oacapture first (supposedly loading a first working firmware on camera) and then switch the camera to the virtual machine, but it doesn't work.

I'm also not on El Capitan but on Yosemite, so it seems it should work but it doesn't. Anyone has a solution to use the asi120 as imager either directly with some software on Mac or on Virtual Machine?

Re: ASI20MM on Mac

Posted: Tue Apr 12, 2016 12:46 pm
by Sam
I did think this problem should due to virtual machine
just try the newest one
I replied you back in email

Re: ASI20MM on Mac

Posted: Tue Apr 12, 2016 10:21 pm
by opoloko
Hi I tried what you suggested by email (VMWARE 8 + WIndows 7 + intel drivers) and it doesn't work.

Like in Parallels (other virtual machine) and Windows XP, your ASI software (or any other) can see the camera, but cannot take any frame from it.

As I said PHD2 on OSX is perfectly able to take frames from the camera, so the problem with Mac is not about buying the USB3, but surely is something that can be solved as well on the USB2 (because PHD2.6 can get frames from it).

Is there any way you can develop a new firmware that can fix this? Your existing firmware (both normal and 'compatible') doesn't work on OSX or Virtual Machine.

Re: ASI20MM on Mac

Posted: Thu Apr 14, 2016 1:21 pm
by opoloko
Hi all,

I finally solved the problem, and I can say the ASI120MM *IS* compatible with Mac / OSX with or without Virtual Machines.

I've done several tests, including download of the SDK and compiling it with new/updated drivers.

In the end this is the procedure to make it work, at least on Yosemite:


1) connect camera to the mac (no drivers available or needed)
2) download oacapture (latest is 0.8 beta), launch it, disable preview. Change exposure to 10ms or more, and max resolution, so you'll have a max theory FPS of about 35 (you can change this later but first make it work)
3) the camera will not work immediately (or will drop frames). Wait a few seconds, open Settings/Camera, change the USB traffic to 50, disable USB traffic (auto) check, and disable the High Speed. As soon as you change the USB traffic to 50, you should start seeing an FPS between 8 and 15, depending on your machine.
4) enable the preview. If you see some irregular squares appearing, change +1 or -1 the USB traffic, that is what makes oacapture 'reset' and camera will work without problems!
5) if you want to enable 16bit, you have to do it now: enable it, frames will stop, to 'reset' oacapture just enable and disable again the 'high speed' in Settings/Camera.

Now you can tweak with settings/expsorue/ROI etc., every time oacapture seems stuck or something is wrong, try changing the USB traffic of just 1 unit, and enabling/disabling high speed, and it will work again.

NOTES: if you enable 16bit as described above, and you close and restart oacapture, 16bit will be enabled BUT IS NOT. You need to disable it, and enable it once the camera is connected to oacapture: when you disconnect from oacapture then is back to 8 bit. Please notice that .SER produced on my setup at 16bit via oacapture seem wrong, so I think there's a bug in oacapture correctly recording 16bit.


This is the option I prefer, because you have Firecapture and Sharpcap. Procedure is simple:

1) launch oacapture and do steps listed above till the camera starts sending frames and you see it's ok in the preview (any setting is fine). This is because oacapture loads on the camera a firmware that is valid and working in the virtual machine, that is unable to do so
2) without disconnecting the camera from the usb, just disconnect it from oacapture. Start Parallels (virtual machine that I tried, with Win XP SP1 32bit), and after you install the asi drivers, start either Firecapture or Sharpcap, making sure you start at 10ms exposure and then you tweak it later. In both programs the camera will work perfectly, and you can achieve up to 10fps and max resolution/16bit! On my Parallels I have USB3 enabled.

Re: ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Fri Apr 15, 2016 3:38 am
by Sam
that's good news!
sorry for the incovinent, that's why we don't suggest Mac user choose our USB2.0 cameras

Re: ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Fri Apr 15, 2016 7:29 am
by opoloko
Hi Sam

It looks long/complicated by the description but is not, it just takes a few seconds to load Oacapture.

I downloaded and compiled your sdk, would be enough for you to do a 'camera loader' and all would work even more quickly (doing what oacapture does that is loading the first firmware on board of camera): most Mac users use virtual machines and that would be all is needed.

I think would be a nicer solution instead of recommending to buy basically the same camera but much more expensive in usb3, although I understand why you do that :)

I'll try developing this loader should beeasy...your cameras are the best price/quality ones out there, I'll upgrade to a bigger one but not for the Mac compatibility because in the end they work well with Mac!

Re: ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Fri Apr 15, 2016 9:20 am
by Sam
thanks for your kind words
the problem is we got some feedbacks that even oacapture cannot preview on some Mac OS
but very few
and the compatible firmware usually slow down the transfer speed

Re: ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Fri Apr 15, 2016 8:55 pm
by opoloko
I carefully debugged what happens, and for what's worth my opinion I think I have a clear idea of what's the problem.

Also I'm NOT using the compatible, I'm using the NORMAL firmware of the ASI120MM, so I achieve quite good framerate (max resolution 16/12bit capture constant 10fps, if I do 8bit it goes to 20fps, always max resolution).

What happens is that as soon as camera is connected, OSX sometimes loads its own driver (typically USB serial one, that is USBCDC), and that basically impedes LibUSB (used by your sdk and oacapture) to connect with the camera.

The simple solution is in what I posted before:

1) waiting a few seconds and correctly configuring oacapture to >10ms exposures
2) changing the USB speed parameter +-1 (that's what 'wakes up' oacapture that then takes control over OSX and is able to load the camera)

This few seconds that sometimes can occurr is what made me thing as well it was not working, because not working I kept changing all parameters (but the wrong ones) and camera was restarting every time.

I tested this with two Yosemite macbooks, using the camera cable, a 5m and 10m usb cables, with a usb2 and usb3 hub, it works always. And once Oacapture connects, it can be used or just closed and camera will work without problems with any Virtual Machine (but if physically disconnected from USB you need to first reload oacapture).

It really looks more complicated than it really is.

You should develop a 'camera loader' made from your SDK, with default >10ms exposure, that just connects to the camera like oacapture, takes a frame and then exits: that way the camera is initialised and ready to be used on Mac.

Re: ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Mon Apr 18, 2016 11:23 pm
by opoloko
As an update to this topic, I have another suggestion that will probably solve ALL REMAINING PROBLEMS OF USING THIS CAMERA WITH A MAC.

After some extensive debugging and testing, I determined and tested on three other Macs that a major problem can be posed by the BLUETOOTH.

Disabling Bluetooth on Mac solved any remaining problem of performance and/or camera recognised by the Mac, Oacaptire and/or any Virtual Machine. This could be because of some kind of weird radio interference, or because of low level bluetooth/usb integration at operating system level.

Following all steps I listed in this topic, and if not working disabling Bluetooth while using the ASI120MM, makes using it on Mac a breeze (and I suspect might solve as well problems of other ASI cameras not working nicely with Mac).

If anyone needs more testing and debugging on Mac, let me know. Provide your feedback if any of these suggestions work or not for you.

Re: ASI20MM on Mac and/or virtual machine: SOLVED

Posted: Fri Jun 03, 2016 3:38 pm
by JamesF
I've only just seen this thread.

In oacapture 0.9.0 there are still a few outstanding USB issues on OSX. I have a test build of the next release on OSX available using the a very recent development version of libusb if anyone would like to try it. Just drop me a pm and I'll give you a download link.