Search found 23 matches

by MikeP
Mon Jan 28, 2019 11:41 am
Forum: SDK & Driver
Topic: ASI 120 Exposure Failed on every first exposure
Replies: 4
Views: 289

Re: ASI 120 Exposure Failed on every first exposure

Thanks Chad, I will bear this in mind. One question about this though: if (CamInfo.bIsUSB3Cam || (CamInfo.Name.ToLower().IndexOf("mini") > -1)) I think one problem with this is that if a user connects a newer USB3 camera with a USB2 cable then the 'IsUSB3Cam' value will be false. Or are you saying t...
by MikeP
Sun Jan 27, 2019 5:53 am
Forum: SDK & Driver
Topic: ASI 120 Exposure Failed on every first exposure
Replies: 4
Views: 289

ASI 120 Exposure Failed on every first exposure

Hi Chad, I've got a user with a strange issue with an ASI 120MC. When he takes images with my application the first exposure always fails. The returned error is ExposureFail. Strangely subsequent exposures work fine with no errors. Can you think of any goo reason why the first exposure fails? Thanks...
by MikeP
Thu Sep 20, 2018 6:24 am
Forum: SDK & Driver
Topic: ASI224MC not found
Replies: 4
Views: 752

Re: ASI224MC not found

Thank you! The problem has now been resolved.

Mike
by MikeP
Tue Sep 18, 2018 10:12 am
Forum: SDK & Driver
Topic: ASI224MC not found
Replies: 4
Views: 752

Re: ASI224MC not found

Thanks Chad I will ask him to look at the device manager, the strange thing though is that it works fine with the ASCOM driver so that would indicate that it is properly connected. Yes please if you could send me the instructions to capture the log that would be helpful. I will send you a private me...
by MikeP
Tue Sep 18, 2018 5:17 am
Forum: SDK & Driver
Topic: ASI224MC not found
Replies: 4
Views: 752

ASI224MC not found

Hi Chad, I was hoping you could help me? I have a user who is trying to use an ASI224MC with my application but when trying to detect connected cameras, GetNumOfConnectedCameras does not return anything. The strange thing though is that the camera is connected and works fine when using the ASCOM dri...
by MikeP
Tue Sep 04, 2018 10:00 am
Forum: SDK & Driver
Topic: Exposure Failed
Replies: 1
Views: 481

Exposure Failed

Hi Chad, I have a problem where sometimes I get into a state where my ASI 178M does not take any exposures anymore, it only reports back 'Exposure Failed' when I check the ASICameraDll2.ExposureStatus.ExpSuccess property every time I try to take an image with my app. Unplugging the camera does not s...
by MikeP
Mon Jul 09, 2018 8:48 pm
Forum: SDK & Driver
Topic: ASI Control Types
Replies: 3
Views: 1019

Re: ASI Control Types

Thanks Chad! And all cameras have the following controls: ASI_GAIN ASI_EXPOSURE ASI_BANDWIDTHOVERLOAD ASI_BRIGHTNESS Is this also correct? Also I have heard that Brightness (e.g. Offset) will be removed as a setting (i.e. fixed) sometime in the future. Is this true? And if so will it be removed from...
by MikeP
Mon Jul 02, 2018 1:23 pm
Forum: SDK & Driver
Topic: ASI Control Types
Replies: 3
Views: 1019

ASI Control Types

Hello, I have a question on the SDK control types that you can use to set camera parameters: public enum ASI_CONTROL_TYPE { ASI_GAIN = 0, ASI_EXPOSURE, ASI_GAMMA, ASI_WB_R, ASI_WB_B, ASI_BRIGHTNESS, ASI_BANDWIDTHOVERLOAD, ASI_OVERCLOCK, ASI_TEMPERATURE, // return 10*temperature ASI_FLIP, ASI_AUTO_MA...
by MikeP
Wed Apr 11, 2018 11:04 am
Forum: SDK & Driver
Topic: ASI120MC Set BANDWIDTHOVERLOAD Error
Replies: 9
Views: 908

Re: ASI120MC Set BANDWIDTHOVERLOAD Error

Hi Chad, Unfortunately that change didn't solve the problem, the same error still persists. When you tested the app did it work on your camera? It's strange because it seems to work fine with other ASI cameras. Not sure if it helps but the code for taking an image is: /// <summary> /// Gets the imag...