Page 1 of 1

ASIAIR PRO and Canon EOS 550D BUSY FREEZE

Posted: Sat May 02, 2020 6:38 pm
by asif
Hi

I've got both an ASIAIR and an ASIAIR PRO and I'm having a problem with the ASIAIR "PRO" recognising the Canon EOS 550D as a "Main Camera"

on the ASIAIR, when the camera is plugged in to the USB PORT, it instantly pops up on the Android ASIAIR APP and shows Canon EOS 550D. Its Flaky but I can setup camera and take shots from the APP.

However, when its plugged into the ASIAIR PRO, the camera instantly freezes with a "BUSY" and the Android APP never detects or shows the Camera in the Main Camera drop down list.

The Camera only recovers when I unplug the USB cable. (When Its reattached, its goes back to camera showing Busy"

I have tried this multiple times; rebooted the PRO; re-flashed the Pro; formatted the SD Card in the Canon and nothing works.

Thanks

ASif.

Re: ASIAIR PRO and Canon EOS 550D BUSY FREEZE

Posted: Wed May 06, 2020 6:47 am
by ASIAIR@ZWO
asif wrote:
Sat May 02, 2020 6:38 pm
Hi

I've got both an ASIAIR and an ASIAIR PRO and I'm having a problem with the ASIAIR "PRO" recognising the Canon EOS 550D as a "Main Camera"

on the ASIAIR, when the camera is plugged in to the USB PORT, it instantly pops up on the Android ASIAIR APP and shows Canon EOS 550D. Its Flaky but I can setup camera and take shots from the APP.

However, when its plugged into the ASIAIR PRO, the camera instantly freezes with a "BUSY" and the Android APP never detects or shows the Camera in the Main Camera drop down list.

The Camera only recovers when I unplug the USB cable. (When Its reattached, its goes back to camera showing Busy"

I have tried this multiple times; rebooted the PRO; re-flashed the Pro; formatted the SD Card in the Canon and nothing works.

Thanks

ASif.
Hey ASif, thanks for your feedback and sorry about the issue, we will try to figure it out and fix it.

Re: ASIAIR PRO and Canon EOS 550D BUSY FREEZE

Posted: Thu May 14, 2020 11:57 am
by asif
Ji.

I've managed to get this to work now.

note: There really needs to be better support mechanism put in place to deal with customer issues. I understand the issues with time difference and covid-19 but the current response times of 2 - 5 days between emails, is not a viable solution to deal with faults easpecially for a product that costs lots of money and has minimal instructions on how to resolve issues.

In any case, as I have a background in linux I figured out that the issue was more than likely with the Pi4 USB Stack. This was also confirmed by the following site. https://www.yoctopuce.com/EN/article/ho ... -usb-stack

Now, not sure if this is a problem with all ASIAIR PRO's shipped or if I got a "dodgy" one, but I was able to resolve the issue with the Camera freezing when connected to the ASIAIR PRO. The App 1.4.3 (5.05) also now picks up the camera in the MAIN Camera drop down list.

I am not going into FULL detail here (if anybody wants to PM me, I am more than happy to share how/what I did in more detail) on how I logged into the ASIAIR as ZWO will more than likely not approve (but I did pay for it so I should not doubt be able to ensure it works if the support channel is not helpful) and it will no doubt invalidate my warranty (i take full responsibility for MY OWN ASIAIR / PRO if it gets bricked, not anybody elses)

anyway:

1) You first need to edit the /etc/apt/sources.list and un#hash the second line in the file.. The first repository didn't work for me, but the .cn one did. so it looks like this

#deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
deb http://mirrors.ustc.edu.cn/raspbian/raspbian/ buster main contrib non-free $
#deb http://mirrors.ustc.edu.cn/raspbian/raspbian/ stretch main contrib non-fre$
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free$

2) you then need to edit the /etc/resolv.conf and add the following nameservers to the list

nameserver 8.8.8.8
nameserver 8.8.4.4


otherwiese you will get a

Temporary failure resolving 'mirrors.ustc.edu.cn', when you try and run the next items:

Once you've done that, run the following:

sudo apt-get install rpi-eeprom
sudo rpi-eeprom-update -a
sudo reboot