ASIAIR autorun randomly stops shooting

Astrophotography has never been easier

Moderators: Sam, Tech@ZWO, ASIAIR@ZWO

herpmcderpington
Posts: 5
Joined: Sun Dec 29, 2019 2:02 am

ASIAIR autorun randomly stops shooting

Post by herpmcderpington » Sun Apr 19, 2020 2:55 pm

Hi,
When using autorun, the Asiair stops shooting after about 1 hour, and freezes for the rest of the night, even though it says "shooting" on the bottom right. I'm using version 1.4.3 on android. Is this a known issue?

EricG
Posts: 8
Joined: Mon Apr 20, 2020 7:18 pm
Location: Paris, France

Re: ASIAIR autorun randomly stops shooting

Post by EricG » Tue Apr 21, 2020 9:43 am

Are you sure it is not link to the guiding of with the dithering ?
Eric
C6 - Celestron AVX
ASIair - ASI533 and ASI1600 with zwo mini filter wheel - ZWO mini guide scope - ASI120mm mini

Nordstern
Posts: 4
Joined: Sat Oct 12, 2019 7:58 pm

Re: ASIAIR autorun randomly stops shooting

Post by Nordstern » Tue Apr 21, 2020 8:52 pm

I have a similar problem. auto run takes a picture and then it doesn't go on? does that not work with the dither function when guiding?

User avatar
mmw09er
Posts: 4
Joined: Sat Feb 08, 2020 3:01 am
Location: Texas, USA

Re: ASIAIR autorun randomly stops shooting

Post by mmw09er » Fri May 01, 2020 8:07 pm

I had this problem last night for the first time... which is odd; the autosequnce stopped / got stuck after 14 captures. Everything worked fine the night before. There is plenty of space on the card so it's not a storage problem.

This morning I was doing some flats and it would get stuck after 2 of 5 captures. The Autorun log for the short session is below:

Log enabled at 2020/05/01 07:33:31
2020/05/01 07:33:31: Start Autorun
2020/05/01 07:33:36: Shooting picture 1#
2020/05/01 07:33:38: Download
2020/05/01 07:33:38: Shooting picture 2#
2020/05/01 07:33:40: Download
2020/05/01 07:33:41: Dither
2020/05/01 07:33:41: Settle
--- Capture progress got stuck here---
2020/05/01 07:34:04: Autorun Stop (I manually stopped it because the progress was stuck on 2 out of 5 captures)
Log disabled at 2020/05/01 07:34:04
Log closed at 2020/05/01 07:34:04

Any ideas why it gets stuck?

Matt

W7AY
Posts: 225
Joined: Fri Jan 25, 2019 3:38 am
Location: Portland, Oregon, USA

Re: ASIAIR autorun randomly stops shooting

Post by W7AY » Sat May 02, 2020 12:28 am

Hi Matt,

Short answer: turn off dithering when taking flats and darks.

What astro hobbyist calls dither is the process of moving the guide star by N pixels every now and then in the X and in the Y directions. (Different from dithering that we learn in college signal processing classes.)

This will cause all stars in the plate to land in a different pixel location to get around anomalies of CMOS sensors. When the stacking program runs, it corrects for the offsets. Once the mount settles down after the dither, the exposure in the main camera starts, and no further dither is applied until at least the end of that plate.

When you are taking darks and flats, there is no guide star. Or you are guiding on a stuck pixel. Either way, dither will never settle down.

When taking Lights, you have to make sure you understand the parameters in Dither Settings. Read up on Dithering in PHD2.

In short, do not exceed your mount's capability when you set the Stability and Settling time. If your stability selection is too small, a cheaper mount may not ever get there (so dither never completes). This can be cause by poor torque from the motors and/or poor backlash in the gears. This why legacy German mounts need to be carefully balanced and carefully biased. Balancing is required for good guiding too. This requirement is not needed for the mounts that use Strain Wave gears (the reason why I left a Takahashi mount for a RainbowAstro RST-135). The RST-135 has so much torque that you do not need a counterweight.

Clear skies
Chen

User avatar
ASIAIR@ZWO
Posts: 501
Joined: Tue May 29, 2018 3:29 am

Re: ASIAIR autorun randomly stops shooting

Post by ASIAIR@ZWO » Wed May 06, 2020 6:53 am

The reason why it stuck cause the dither never to settle down. In the new version, we set a 60 timeout on the settle. After that, the autorun will continue.
ZWO | ASIAIR Support
Location:lon=120.6 lat=31.3
Suzhou China

User avatar
mmw09er
Posts: 4
Joined: Sat Feb 08, 2020 3:01 am
Location: Texas, USA

Re: ASIAIR autorun randomly stops shooting

Post by mmw09er » Wed May 06, 2020 8:13 pm

Many thanks, Ji.zwo and W7AY! I appreciate your explanations - they make complete sense! Clear skies! Matt

User avatar
ASIAIR@ZWO
Posts: 501
Joined: Tue May 29, 2018 3:29 am

Re: ASIAIR autorun randomly stops shooting

Post by ASIAIR@ZWO » Sat May 09, 2020 7:14 am

mmw09er wrote:
Wed May 06, 2020 8:13 pm
Many thanks, Ji.zwo and W7AY! I appreciate your explanations - they make complete sense! Clear skies! Matt
In v1.4.4 we set the dither settles down timeout to 60 sec. This would fix the issue.
ZWO | ASIAIR Support
Location:lon=120.6 lat=31.3
Suzhou China

User avatar
mmw09er
Posts: 4
Joined: Sat Feb 08, 2020 3:01 am
Location: Texas, USA

Re: ASIAIR autorun randomly stops shooting

Post by mmw09er » Tue May 19, 2020 1:03 pm

OK... so finally after some additional attempts: I am still having the failed autorun procedure. Dithering is turned off. Last night's logs reveal it may be due to meridian flip complications. See attached log snippet imaging M51 from San Antonio, Texas. After 5 attempts to do the flip the unit gets stuck in a loop auto centering/platesolving. Any ideas?

2020/05/18 23:10:19: Shooting picture 20#. (the last photo that succeeded)
2020/05/18 23:14:21: Download
2020/05/18 23:14:31: Wait for Meridian Flip 1# (there were four more meridian flip sequences like these next few lines)
2020/05/18 23:14:31: Stop Guiding
2020/05/18 23:14:31: Stop Tracking
2020/05/18 23:21:06: Auto-Center Start
2020/05/18 23:21:13: Download
2020/05/18 23:21:23: Auto-Center 1#
2020/05/18 23:21:23: Mount slews to target position
2020/05/18 23:21:27: Expose
2020/05/18 23:21:34: Download
2020/05/18 23:21:35: Plate Solve
2020/05/18 23:21:37: Auto-Center Failed merid flip failed

The final meridian flip related log entry does something different
2020/05/18 23:25:41: Wait for Meridian Flip 5#
2020/05/18 23:26:41: Auto-Center Start
2020/05/18 23:26:48: Download
2020/05/18 23:26:52: Auto-Center 1#. (these last lines repeated over and over 1,200 times until I stopped Autorun.)
2020/05/18 23:26:52: Mount slews to target position
2020/05/18 23:26:55: Expose
2020/05/18 23:27:02: Download
2020/05/18 23:27:02: Plate Solve


I have come to think that maybe the Meridian Flip settings of the mount could interfere with things - what if it did a meridian flip before the ASIAir expected it, etc? Tonight I made change to my mount's settings (Ioptron CEM60) so that the ASIair should have a chance to manage the meridian flip before the mount is set to do it; and therefore should operate normally.

User avatar
mmw09er
Posts: 4
Joined: Sat Feb 08, 2020 3:01 am
Location: Texas, USA

Re: ASIAIR autorun randomly stops shooting

Post by mmw09er » Mon Jun 08, 2020 10:13 pm

Replying to my own post to close this out ... as assistance to anyone else in the future.

I finally caught this in the act!

I verified that the ASIair was set to perform the meridian flip before the CEM60 was. I assume that if the CEM does it independent of the ASIair,then the ASIair would not know about the flip, and would therefore a) not plate solve to confirm it and b) later on it would attempt its own flip messing things up even worse. Better to let ASIair do it so it's workflow has a chance - i.e. plate solving upon completion to center the target again.

I think a point of failure I experienced last time - if clouds have come out or the focus of the primary or guider are affected by the flip, then ASIair cannot correctly verify the object is centered after the flip and therefore imaging workflow does not resume.

Post Reply