Page 1 of 1

ASI 178MM on BeagleBone Black with Debian

PostPosted: Mon Feb 12, 2018 11:53 pm
by jdlogicman
I'm trying to get the camera working on a Beaglebone Black running Debian with kernel 4.9.78-ti-r94. This is similar to a Raspberry Pi.

The USB device shows up in lsusb but no video0 device shows up in /dev. I

I ran the demos here: . The SDK can talk to the camera to get and set properties, but image capture always fails.

Any advice?

Edit: hwinfo --usb shows this:
06: USB 00.0: 0000 Unclassified device
[Created at usb.122]
Unique ID: ADDn.VeIeLjDBstD
Parent ID: k4bc.dZ4ztSBeww5
SysFS ID: /devices/platform/ocp/47400000.usb/47401c00.usb/musb-hdrc.1/usb1/1-1/1-1:1.0
SysFS BusID: 1-1:1.0
Hardware Class: unknown
Model: "ZWO ASI178MM"
Hotplug: USB
Vendor: usb 0x03c3 "ZWO"
Device: usb 0x178c "ASI178MM"
Speed: 480 Mbps
Module Alias: "usb:v03C3p178Cd0000dc00dsc00dp00icFFisc00ip00in00"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #5 (Hub)

Re: ASI 178MM on BeagleBone Black with Debian

PostPosted: Sat Feb 17, 2018 9:27 am
by JamesF
Devices only appear as /dev/video... when there's a kernel-space driver for them that provides a V4L2-compliant interface. The SDK provides a driver entirely in user-space and connects directly via the USB interface rather than V4L2, so it's not a concern that there's no /dev/video device.

I have a BeagleBone Black, but I have to admit that I've never tried it with an ASI camera. I wonder if there's perhaps not enough bandwidth on the USB bus to handle the frame size? Are there any errors in the system logs? When I have a moment I'll try to give my software a go on it.