[SOLVED] indi_asi_ccd crashed on ASI ZWO 183MM capture

any question related to our SDK and driver

Moderators: yang, ray, chad

Re: indi_asi_ccd crashed when start capturing for ASI ZWO 18

Postby yang » Tue Jan 16, 2018 9:20 am

I download source code of INDI from github and build, find that ASI183 works normally, do you install INDI with apt-get?
ZWO software engineer
Location:lon=120.6 lat=31.3
SuZhou China
yang
Site Admin
 
Posts: 204
Joined: Fri Jul 25, 2014 2:43 am

Re: indi_asi_ccd crashed when start capturing for ASI ZWO 18

Postby sywong2000 » Tue Jan 16, 2018 9:49 am

Hi Yang,

On ubuntu, yes I install from apt-get. I did attempted to get the source and build again. I rebuild indi, indi-asi and kstars. But same error.

I will try later to apt purge the one i've installed to make sure the pre-built binaries are cleaned up, and rebuild again and let you know.

Stephen
sywong2000
 
Posts: 13
Joined: Sun Jan 07, 2018 2:45 pm

[SOLVED] Re: indi_asi_ccd crashed start capturing ASI ZWO 18

Postby sywong2000 » Wed Jan 17, 2018 3:48 am

Dear all,

After rebuild in ubuntu, same problem occurs. But then I recheck the settings once again, and found it was a silly mistake.

The USB buffer in libusb was set to 16Mb only. When I first set the usb buffer to 200, I must have simply cat it once from the terminal and forgot to update the rule file /etc/udev/rules.d/ folder.

So when I reboot the Pi, the system the buffer is set back to 16. That was what caused the problem. After I added the buffer settings in the asi rule file, the problem is gone.. and now everything is good.

Thanks for everyone's help on this.
Stephen
sywong2000
 
Posts: 13
Joined: Sun Jan 07, 2018 2:45 pm

Previous

Return to SDK & Driver

Who is online

Users browsing this forum: No registered users and 2 guests