ASI 120 MC -- Firmware upgraded

any question related to our SDK and driver

Moderators: yang, ray, chad

Re: ASI 120 MC -- Firmware upgraded

Postby JamesF » Thu Dec 21, 2017 12:04 pm

In case it's helpful, I just had to flash my 120MC to the "compatible" firmware to get it to work on both 64-bit Linux Mint 18 and on Raspbian 9.

James
JamesF
 
Posts: 88
Joined: Wed Feb 20, 2013 10:27 pm

Re: ASI 120 MC -- Firmware upgraded

Postby wulfblat » Fri Jan 05, 2018 5:45 pm

chad wrote:Hi,
Please download this attachment. and try to upgraded the firmware again.
Thanks
chad


Hi Chad,

I downloaded this attachment and used it to flash my old ASI120MM, and the command succeeded, but now the camera is not functioning at all.

Here is the command I ran (from the x64 directory):

./zwo_FWTool_USB2 -i ../firmware/ASI120MM-compatible.iic -t li2c

The command succeeded, but after this the camera no longer functions.

Here is the output of dmesg covering the time just before the firmware was updated to just after:

[37909.858648] usb 1-2: new high-speed USB device number 13 using xhci_hcd
[37910.127207] usb 1-2: config 1 interface 0 altsetting 0 endpoint 0x82 has invalid maxpacket 1024, setting to 512
[37910.127555] usb 1-2: New USB device found, idVendor=03c3, idProduct=120a
[37910.127559] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[37910.127561] usb 1-2: Product: ASI120MM
[37910.127564] usb 1-2: Manufacturer: ZWOptical company
[37910.127566] usb 1-2: SerialNumber: 00000
[38024.126483] usb 1-2: reset high-speed USB device number 13 using xhci_hcd
[38026.340606] usb 1-2: USB disconnect, device number 13
[38028.926503] usb 1-2: new high-speed USB device number 14 using xhci_hcd
[38034.174560] usb 1-2: device descriptor read/64, error -110

I unplugged the camera and then plugged it back in, but to no avail.

I then tried to update the firmware again, but I am afraid the damage has been done, because now zwo_FWTool_USB2 reports the following:

Error: No FX2LP device found

Is there any way to recover this camera?

Leonard
User avatar
wulfblat
 
Posts: 13
Joined: Thu Jan 04, 2018 4:19 pm
Location: Prineville, OR USA

Re: ASI 120 MC -- Firmware upgraded

Postby chad » Mon Jan 08, 2018 1:58 am

Hi all,
If there is no problem with your camera, please do not use this upgrade package easily。
There are some things inside the tool that are encapsulated by others (not us) and they are not safe. Even if the update goes wrong, it may return to success. So please don't use this tool to upgrade unless you have to.

Hi Leonard,
Please try another usb ports. If it failed, please change a USB cable. If it still failed, plug it into a windows PC. If it still failed, send a email to me, and I will help you check it by remote control. If all of them do not work, the camera is broken. You have to send it back.

Thanks
chad
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China
User avatar
chad
 
Posts: 148
Joined: Thu Feb 09, 2017 4:58 am

Previous

Return to SDK & Driver

Who is online

Users browsing this forum: No registered users and 1 guest