ASI120MC driver failed (code 10)

any question related to our SDK and driver

Moderators: yang, ray, chad

Post Reply
GunterG
Posts: 2
Joined: Thu Nov 21, 2019 8:18 pm

ASI120MC driver failed (code 10)

Post by GunterG » Fri Nov 22, 2019 6:50 pm

I purchased a new laptop for my telescope gear. All the drivers are installed. I run a Ioptron mount, a ASI183, a ZWO focuser, and a ASI120 as a guide camera. I am running win10 home. When i connect, everything starts up, but the asi120. It shows "driver error" code 10. I checked with microsoft, and code 10 is the inability for windows to load the driver for that device. My old laptop runs all this equipment just fine. I removed the drivers and reinstalled them three times, I removed all the equipment, leaving only the asi120 plugged in, but it still shows the same problem. I am not a software engineer so at this time, I am at a loss. The only thing I can think of, is the camera drivers on my old laptop are over a year old, and the new one have been just downloaded a couple days ago. I would be happy to listen to any ideas on this problem. :cry:

User avatar
chad
Posts: 635
Joined: Thu Feb 09, 2017 4:58 am

Re: ASI120MC driver failed (code 10)

Post by chad » Sat Nov 23, 2019 6:38 am

Hi,
Sorry for the problem.
First, I think you can try to test it on another computer, if it works well, then try the step 3 of this URL:
https://windowsinstructed.com/solve-cod ... e-manager/
Or you also could try this method 4 of this URL:
https://www.repairwin.com/fix-usb-devic ... -10-error/
Thanks
Chad
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China

GunterG
Posts: 2
Joined: Thu Nov 21, 2019 8:18 pm

Re: ASI120MC driver failed (code 10)

Post by GunterG » Sun Nov 24, 2019 7:57 pm

Thank you Chad for replying so fast, unfortunately none of the instructions solved this problem. I deleted everything from this laptop, reloaded windows and only loaded the camera driver and the asicap software. It still did not work, the same error code 10 came up. I loaded the camera driver on two other laptops and the camera worked. The only difference is the non working laptop is brand new with the newest version of win10. Why the asi183 camera works, and the asi120 does not is a total mystery.
Gunter

User avatar
chad
Posts: 635
Joined: Thu Feb 09, 2017 4:58 am

Re: ASI120MC driver failed (code 10)

Post by chad » Thu Dec 05, 2019 5:39 am

Hi Gunter,
As you know, 120MC is our first generation product. At that time, USB2.0 is the most widely used. But now, USB3.0 is used widely. Although in theory it should be compatible, in fact it is still problematic under some strict conditions. So in this case, it is hard to say what happened.
For the current, you can test it with a USB2.0 Hub. Maybe it works. And we really can't help you much on this problem.
Thanks
Chad
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China

Post Reply