Page 1 of 1

ASI183mm Pro + EFW drivers slow to load in SGP?

Posted: Mon May 11, 2020 4:14 pm
by richbandit
Sirs,

Are you able to assist!

I've been successfully using my ASI183mm Pro Cooled camera + ZWO EFW with Sequence Generator Pro for a good 18 months or so, and once initially set up I never had any problems. I recently find that both of these are now taking ages to 'load' their respective drivers (min. 20 seconds or so?) in SGP and I can't figure out why …. I've tried both ZWO and ASCOM drivers for each, but same thing now happening, also tried removing & reloading drivers but no difference. As far as I'm aware I haven't changed any related setting (not had the need to), this effect seemed to suddenly appear from no-where! I note that once the first one of the drivers has finally 'loaded', the second one then has no delay (whichever way round I load them).

I'm aware that SGP now advises it doesn't support the ASI183mm driver (not sure about the EFW?), but it always still worked OK … so wondering if this may be causing the condition I changed over to the ASCOM driver(s) - but still the same issue.

All controlled for the last 6 months by a stand-alone Intel NUC PC (no Internet connection), but fail to see if that may be causing a problem as it's worked flawlessly up until recently! Whilst this isn't a 'critical' failure, it's certainly an annoyance!

Any advice or pointers you could advise please so I can try to track this down?

Many thanks,

Richard

Re: ASI183mm Pro + EFW drivers slow to load in SGP?

Posted: Wed May 13, 2020 10:34 am
by Moson
We have some advices for your reference:
1. Try to replace the data cable, interface and computer.
2. Test again in our ASIStudio software.
3. Update the latest version of the driver.

Re: ASI183mm Pro + EFW drivers slow to load in SGP?

Posted: Thu May 14, 2020 2:16 pm
by richbandit
Hi Moson,

Many thanks for your advice. Problem resolved - in case it might help anyone else, this was the solution:

- Connected to a different computer and the drivers loaded immediately in SGP! So, definitely the cause was related to the original computer somehow.
- Back on original computer, replaced cable(s), re-loaded drivers once again (they were the very latest versions anyway) and re-checked everything I could think of; but no change - problem still exists!

So what's going on?

Out of curiosity and being at a bit of a loss, thought I'd check if there was an upgrade to SGP …. and there was (only small upgrade since previous version, but even so). So connected original computer to internet, downloaded & installed new SGP version and then tested again …

- Would you believe it, now the drivers seem to work just fine and load instantly as expected!! I've done nothing else new other than start up the latest version of SGP ...

Conclusion - SGP must have had a bug introduced on a more recent upgrade (this would explain why the issue suddenly appeared with no apparent reason) which would now appear to be resolved, and I'm a happy bunny again!

Thanks again for your guidance - so if anyone else has this problem, upgrade SGP to latest version first before diving in and changing any settings!

Richard

Re: ASI183mm Pro + EFW drivers slow to load in SGP?

Posted: Fri May 15, 2020 2:55 am
by Moson
Thank you very much for your feedback! And we will record this.